FICHIERS DE DÉPLOIEMENT XML

FICHIERS XML – EXEMPLE

A – Fichiers de boot à placer dans les propriétés du serveur –> Onglet client

Le rôle de ses deux fichiers est de permettre la création automatique d’une partition  C: et de connecter le logiciel au domaine afin de pouvoir choisir l’image à déployer.

Ces 2 fichiers sont à personnaliser avant l’import sur le serveur WDS : dans la partie « login » indiquer le nom du domaine, de l’administrateur et son mot de passe

<Login>
<Credentials>
<Domain>d-olympe.local</Domain>
<Username>admin</Username>
<Password>XXXXXXXXXX</Password>
</Credentials>
</Login>

FICHIER 1 : pour machines BIOS Architecture x64

FICHIER 2 : pour machines UEFI Architecture x64 UEFI


B – Fichier de déploiement :

à placer sur chaque image.

Fichier d’automatisation de la première configuration de la nouvelle image

Création automatique du premier utilisateur local : Mod_loc avec son mot de passe. Connection de cet utilisateur en fin de deploiement.

FICHIER 3 : fichier de boot avec création et connexion de Mod_loc

 


 

C – Fichiers de boot et de déploiement plus complets – A tester

 

Réponse de Th Ch à Antoine

Le pb est dans ton fichier de démarrage, qui serait adapté à un disque vierge.

S’il y a déjà des partitions existantes, il faut d’abord faire le ménage avec un willwipedisk égal à true dans une section disk configuration qui contiendrait par exemple :

<DiskConfiguration>

<Disk wcm:action= »modify »>

<DiskID>0</DiskID>

<WillWipeDisk>true</WillWipeDisk>

<CreatePartitions>

<CreatePartition wcm:action= »add »>

<Order>1</Order>

<Size>350</Size>

<Type>Primary</Type>

</CreatePartition>

<CreatePartition wcm:action= »add »>

<Order>2</Order>

<Type>Primary</Type>

<Extend>true</Extend>

</CreatePartition>

</CreatePartitions>

<ModifyPartitions>

<ModifyPartition wcm:action= »add »>

<Order>1</Order>

<PartitionID>1</PartitionID>

<Label>System</Label>

<Format>NTFS</Format>

<Active>true</Active>

</ModifyPartition>

<ModifyPartition wcm:action= »add »>

<Order>2</Order>

<PartitionID>2</PartitionID>

<Label>Windows</Label>

<Format>NTFS</Format>

</ModifyPartition>

</ModifyPartitions>

</Disk>

</DiskConfiguration>

 

 

 

 

Fichier réponse de démarrage du LPRO de BEAUMONT qui ne supprime pas les partitions et ne fonctionne donc pas sur des machiens qui ont déjà été installées.

<?xml version= »1.0″ encoding= »utf-8″?>

<unattend xmlns= »urn:schemas-microsoft-com:unattend »>

<settings pass= »windowsPE »>

<component name= »Microsoft-Windows-International-Core-WinPE » processorArchitecture= »amd64″ publicKeyToken= »31bf3856ad364e35″ language= »neutral » versionScope= »nonSxS » xmlns:wcm= »http://schemas.microsoft.com/WMIConfig/2002/State » xmlns:xsi= »http://www.w3.org/2001/XMLSchema-instance« >

<SetupUILanguage>

<UILanguage>fr-FR</UILanguage>

</SetupUILanguage>

</component>

<component name= »Microsoft-Windows-Setup » processorArchitecture= »amd64″ publicKeyToken= »31bf3856ad364e35″ language= »neutral » versionScope= »nonSxS » xmlns:wcm= »http://schemas.microsoft.com/WMIConfig/2002/State » xmlns:xsi= »http://www.w3.org/2001/XMLSchema-instance« >

<WindowsDeploymentServices>

<Login>

<Credentials>

<Domain>D-LPBEAUMONT.local</Domain>

<Password>*******</Password>

<Username>ADMINSTA</Username>

</Credentials>

</Login>

<ImageSelection>

<InstallImage>

<Filename>w7topo.wim</Filename>

<ImageName>w7topo</ImageName>

<ImageGroup>W7_captured</ImageGroup>

</InstallImage>

<InstallTo>

<DiskID>0</DiskID>

<PartitionID>1</PartitionID>

</InstallTo>

</ImageSelection>

</WindowsDeploymentServices>

<DiskConfiguration>

<Disk wcm:action= »modify »>

<ModifyPartitions>

<ModifyPartition wcm:action= »add »>

<Format>NTFS</Format>

<Order>1</Order>

<PartitionID>1</PartitionID>

</ModifyPartition>

</ModifyPartitions>

<DiskID>0</DiskID>

</Disk>

</DiskConfiguration>

</component>

</settings>

<cpi:offlineImage cpi:source= »wim://serveur01/reminst/sources/w8.1/install.wim#Windows 8.1 Pro » xmlns:cpi= »urn:schemas-microsoft-com:cpi » />

</unattend>

 

 

Fichier réponse d’installation de Beaumont

<?xml version= »1.0″ encoding= »utf-8″?>

<unattend xmlns= »urn:schemas-microsoft-com:unattend »>

<settings pass= »windowsPE »>

<component name= »Microsoft-Windows-International-Core-WinPE » processorArchitecture= »amd64″ publicKeyToken= »31bf3856ad364e35″ language= »neutral » versionScope= »nonSxS » xmlns:wcm= »http://schemas.microsoft.com/WMIConfig/2002/State » xmlns:xsi= »http://www.w3.org/2001/XMLSchema-instance« >

<SetupUILanguage>

<UILanguage>fr-FR</UILanguage>

</SetupUILanguage>

</component>

</settings>

<settings pass= »specialize »>

<component name= »Microsoft-Windows-Shell-Setup » processorArchitecture= »amd64″ publicKeyToken= »31bf3856ad364e35″ language= »neutral » versionScope= »nonSxS » xmlns:wcm= »http://schemas.microsoft.com/WMIConfig/2002/State » xmlns:xsi= »http://www.w3.org/2001/XMLSchema-instance« >

<TimeZone>Romance Standard Time</TimeZone>

<ComputerName>*</ComputerName>

<RegisteredOrganization>EN</RegisteredOrganization>

<RegisteredOwner>EN</RegisteredOwner>

</component>

<component name= »Microsoft-Windows-UnattendedJoin » processorArchitecture= »amd64″ publicKeyToken= »31bf3856ad364e35″ language= »neutral » versionScope= »nonSxS » xmlns:wcm= »http://schemas.microsoft.com/WMIConfig/2002/State » xmlns:xsi= »http://www.w3.org/2001/XMLSchema-instance« >

<Identification>

<Credentials>

<Domain>D-LPBEAUMONT.local</Domain>

<Password>******</Password>

<Username>ADMINSTA</Username>

</Credentials>

<JoinDomain>D-LPBEAUMONT.local</JoinDomain>

</Identification>

</component>

</settings>

<settings pass= »oobeSystem »>

<component name= »Microsoft-Windows-Shell-Setup » processorArchitecture= »amd64″ publicKeyToken= »31bf3856ad364e35″ language= »neutral » versionScope= »nonSxS » xmlns:wcm= »http://schemas.microsoft.com/WMIConfig/2002/State » xmlns:xsi= »http://www.w3.org/2001/XMLSchema-instance« >

<OOBE>

<HideEULAPage>true</HideEULAPage>

<HideLocalAccountScreen>true</HideLocalAccountScreen>

<HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>

<HideOnlineAccountScreens>true</HideOnlineAccountScreens>

<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>

<ProtectYourPC>3</ProtectYourPC>

</OOBE>

<UserAccounts>

<LocalAccounts>

<LocalAccount wcm:action= »add »>

<Description>Modele local</Description>

<DisplayName>mod_loc</DisplayName>

<Group>Administrators</Group>

<Name>mod_loc</Name>

</LocalAccount>

</LocalAccounts>

</UserAccounts>

</component>

<component name= »Microsoft-Windows-International-Core » processorArchitecture= »amd64″ publicKeyToken= »31bf3856ad364e35″ language= »neutral » versionScope= »nonSxS » xmlns:wcm= »http://schemas.microsoft.com/WMIConfig/2002/State » xmlns:xsi= »http://www.w3.org/2001/XMLSchema-instance« >

<InputLocale>fr-FR</InputLocale>

<SystemLocale>fr-FR</SystemLocale>

<UILanguage>fr-FR</UILanguage>

<UserLocale>fr-FR</UserLocale>

</component>

</settings>

<cpi:offlineImage cpi:source= »wim://serveur01/reminst/sources/w8.1/install.wim#Windows 8.1 Pro » xmlns:cpi= »urn:schemas-microsoft-com:cpi » />

</unattend>

 

 

De : Chassain Thierry <chassain@ac-toulouse.fr>
Envoyé : mercredi 23 janvier 2019 09:43
À : Fiault Antoine <Antoine.Fiault@ac-toulouse.fr>; magret.tice31@ac-toulouse.fr
Objet : RE: [Magret] Capture image WDS

 

Ce pb est fréquent, et il faudrait mettre à jour AIK à chaque version de Windows…..

 

Mais il est facile à contourner :

– Pour la cature, on enregistre l’image .wim en local directement sur C:\temp (mais vu dans WinPE comme D:\Temp).

– On redémarre la machine master, CTRL+SHIFT+F3 pour passer en mode audit

– On connecte un lecteur réseau sur le serveur WDS et on y transfère l’image .wim

– Sur le serveur WDS, dans la console de gestion du service de déploiement, il suffit d’importer dans cette image dans la rubrique image d’installation (clic droit). L’opération est un peu longue à cause du contrôle d’intégrité de l’image.